Instalar aircrack-ng en Ubuntu 12.04

by DENIS BALIBOUSE

Después de actualizar una de mis maquinas a Lubuntu 12.04 me di cuenta de que los paquetes de aircrack ya no estaban disponibles en el centro de software, parece que es una decisión de Canonical que afecta a todos los derivados de Ubuntu, así que si queremos tener esta suite de seguridad inhalambrica y no nos apetece ponernos a compilar, lo mejor es descargar los paquetes deb (32 bits,64 bits) disponibles desde launchpad.

Para hacer la instalación , una vez descargado el paquete correspondiente, lo podemos hacer con Gdebi haciendo doble click sobre el paquete o bien mediante la terminal:

sudo apt-get install aircrack-ng_1.1-1.1build1_i386.deb

sudo apt-get install aircrack-ng_1.1-1.1build1_amd64.deb

Y en unos segundos tendremos aircrack instalado y listo para hacer cualquier test de seguridad a redes wifi.

26 thoughts on “Instalar aircrack-ng en Ubuntu 12.04”

  1. Luweeds (@Luweeds) says:

    Te agradezco especialmente éste post, que soluciona la aparente censura (en mi opinión) de software libre, el software tiene que ser legal y su uso irá en consonancia con la ética del individuo que lo use. Se tiene la tendencia a tomar el control desmesurado de los ciudadanos/clientes, el software libre además de la Libertad hace apología de valores como el interés por el conocimiento por lo que cualquier censura debe ser rechazada. Otros valores del software libre son Compartir y Ayudar, y para muestra éste post. Gracias de nuevo Tannhausser
    PD: Lo prohibido sabe mejor

  2. tannhausser says:

    Coincido totalmente contigo y me recuerda una noticia que leí hace unas semanas en las que la UE se planteaba prohibir la tenencia de herramientas de hacking http://bit.ly/KcAwt3 . Es como si prohibieran usar coches, porque también puedes matar a alguién con el XD.
    El caso es que yendo al tema de aircrack, tampoco se porque no está en los repositorios de Ubuntu, no es mi distro habitual (lo usa mi novia, yo soy mas de OpenSUSE) y apenas sigo los foros, pero puede que sea un problema de dependencias/paquetes en su momento y no de censura. I don’t know..
    En cuanto a los valores del software libre a veces a algunos usuarios veteranos se les olvida (de los nuevos que vienen de windows no digo nada, bastante tienen con instalar el sistema e ir aprendiendo poco a poco), así que ves a gente veterana con declaraciones como “a mi si es libre o privativo me da igual el caso es que funcione” o la clásica “Stallman está loco” (aunque gracias a ese loco, su filosofía y la de otros, utilizan un sistema operativo como la gente..) o “deberíamos acercar linux al usuario común y que hubiera una sola distro” claro ahí se refieren a la suya, y cuando dicen el usuario común están pensando en un usuario idiota, porque hoy en día las distros grandes son fáciles de manejar, el principal problema para su adopción en masa, es que no vienen preinstaladas en los ordenadores como lo hace windows.
    En definitiva que el movimiento del software libre está fundamentado en los conceptos libertad y compartir conocimientos (copyleft), que la gente es libre para no ser libre, es decir para usar software privativo está claro, pero que después no se tiren el rollito linuxero, que no traga :-)

  3. Luweeds (@Luweeds) says:

    Yo sufrí también problemas con aircrack en Debian hace ya tiempo y tardaron en resolverlo, pero fue por problemas técnicos con módulos del kernel. No se por qué, no está en el Centro de Software Ubuntu, pero sí se que hay intereses en intentar criminalizar software de seguridad informática a nivel mundial (cómo bien señalas en el enlace), es algo a lo que no debemos llegar pues se impediría que muchos usuarios se vieran atraidos por redes, hacking e incluso cracking, los cuales no son mas que conocimientos técnicos.
    Respecto a la variedad de distros, coincido con muchos, en que hay una bestialidad de forks de distros, no se cual sería el número idóneo (al menos 4 ó 5 sí creo que deben existir) para que los éxitos de unas se implementen en otras, y así conseguir una distro ultracompetitiva respecto a otros O.S.
    No hay que olvidar que cada usuario tiene sus necesidades y a lo mejor lo que a uno le vale a otro no (además del hardware con el que cuente). La Libertad del usuario de elegir para mí es lo importante y la capacidad de compartir es lo que más admiro del Software libre…Yo siempre estaré probando distintas distros porque me divierte y no porque busque una en particular. Ubuntu hace y a hecho mucho, pero yo lo veo todo como una gran familia. Gracias por dejar expresarme en tu blog, e un placer. ;)

  4. ox1d0 says:

    @tannhausser Dependencias cuando lo puedes compilar .. ??

    Seguro es censura .. por mi mejor asi haber si comienzan a usar Distribuciones Libres Gnu/Linux de verdad ..

  5. WildTux says:

    El problema es que simplemente instalado el paquete deb no funciona correctamente el programa. Aquí http://t.co/848hSYyG hay una forma de “parchearlo” para evitar el viejo error mon0 en -1 Por lo que dicen en los comentarios hay gente a la que le ha funcionado sin problemas, a otros no (como es mi caso)

    Saludos

  6. tannhausser says:

    Parece que también esta fuera de todas las ramas de Debian, por problemas de licencia y mantenimiento, aquí el hilo para quien le interese http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=642934

  7. julio says:

    me salvastes, recien estoy probando el Ubuntu en esta version, y tenia este problema, saludos. thank’s.

    1. tannhausser says:

      Me alegro de que te funcionase.
      Un saludo!

  8. Pedro27 says:

    ola perdona las molestias pero puedes poner un link para la descargar del programa por que lo pongo en la terminal y me dice que no lo encuentra gracias

    1. tannhausser says:

      Probaste a pinchar en los enlaces que pone 32 y 64 bits? A mi si me funcionan…
      Saludos!

  9. lol says:

    Muchas gracias por la ayuda, acababa de instalar la 12.04 y no entendía el problema.

    Comentar que el típico problema del channel en -1 depende de la tarjeta de red usada y los drivers instalados, cada cual deberá conocer su chipset, saber si es compatible e instalar el driver adecuado. He leído de todo por la web pero resolver esto es lo único que me lo solucionó.

    1. tannhausser says:

      Gracias a ti lol. Lo que comentas de las tarjetas es cierto no todos los modelos y drivers funcionan con aircrack, aquí tenéis una lista de tarjetas compatibles http://www.aircrack-ng.org/doku.php?id=compatibility_drivers

  10. azpersor says:

    hola en el linck de las tarjetas soportadas no vi mi tarjeta es una tl-wn7200nd…. o alguien sabe alguna forma de ver exactamente el chip que se tiene sin necesidad de abrir el aparato

    1. tannhausser says:

      Hola! Prueba a ejecutar alguno de estos comandos como root:
      lspci | grep Network
      hwinfo –short

  11. AZPERSOR says:

    GRACIAS HASTA EL MOMENTO NO E TENIDO PROBLEMAS. Y YA NO ES NECESARIO LO DEL CHIP…. ME RECONOCIO DESDE EL INICIO LA TARJETA E INSTALE EL PAQUETE DEB, INICIE EL AIRMON, NO ME DIO PROBLEMAS PARA PONER EN MODO MONITOR…. MUCHAS GRACIAS DE ANTEMANO tannhausser

  12. zeroxcode says:

    alguien me ayude con los comandos de esta nueva version de aircrack????, saludos brother tu post esta increible

  13. Marcos says:

    gracias men:)

  14. Antonio says:

    Problem….. me dice que:

    Leyendo lista de paquetes… Hecho
    Creando árbol de dependencias
    Leyendo la información de estado… Hecho
    E: No se ha podido localizar el paquete aircrack-ng_1.1-1.1build1amd64.deb
    E: No se pudo encontrar ningún paquete con la expresión regular «aircrack-ng_1.1-1.1build1amd64.deb»

    que es lo que me pasa amigo?

    1. MaxxKcoronado says:

      Hola, reemplaza el comando “apt-get install” por “dpkg -i” por ejemplo así:

      $ sudo dpkg – i aircrack-ng_1.1-4_i386.deb

  15. jose says:

    ya instale aircrack para ubuntu 12.04 desde el terminal ahora como lo ejecuto

  16. tannhausser says:

    aircrack-ng

  17. jose says:

    ejecute aircrack-ng desde el terminal y en la ultima linea me pone no file to crack specified que tengo que hacer

    1. Cora says:

      ami tmb me sale lo mismo como lo has solucionado¿

  18. Sergio says:

    encontre este enlace como archivo .deb para 12.04 LTS

    https://launchpad.net/ubuntu/precise/i386/aircrack-ng/1:1.1-1.1build1

    Saludos

    1. tannhausser says:

      Gracias por el aporte!
      Un saludo!

  19. St0rmt4il says:

    Que tal si colocarias algo de snort y nessus!?

    Otra cosa, para instalarlo seria mas facil con un dpkg -i [paquete] :D

    Saludos!

Deja un comentario

A %d blogueros les gusta esto: