Activar KDE rolling release en openSUSE con los nuevos repos current

opensuse_repo_current_image5

Interesantes novedades para los usuarios de la distro del Gecko, especialmente los amantes de KDE. Como todos sabéis hasta ahora cada vez que queríamos disfrutar de las ultimas novedades de KDE en una versión estable de openSUSE, los desarrolladores de esta distro nos ofrecían la posibilidad de acceder a ellos mediante los repositorios openSUSE KDE:Release:xy.

Los cuales precisabamos cambiar cada vez que salía una nueva versión de este escritorio (KDE 4.11, KDE 4.12, KDE 4.13 etc..) si queríamos estar a la última.

Ese cambio de repos continuo, ya no será necesario, ahora bastará con activar unos nuevos repositorios llamados “current” con los que nos mantendremos siempre actualizados a la última corriente de KDE, sin necesidad de tocar nada.

Por supuesto, esta activación de repositorios es opcional, los usuarios pueden seguir con las versiones KDE que vienen con cada versión de openSUSE (lo que seguramente les garantizará mayor estabilidad) plenamente actualizadas y mantenidas por el equipo de la distro.

Además seguirán estando disponibles repositorios como KDE:Distro:Factory donde se situarían las betas y versiones candidatas. Así como KDE:Unstable:SC como rama inestable de pruebas, para los más impacientes

En total y recapitulando 4 repositorios diferentes para elegir: el que viene de serie con cada versión de la distro, KDE:Current, KDE:Distro:Factory y KDE:Unstable:SC

Ahora vamos a ver como instalar el repo de KDE:Current para proporcionar esa experiencia KDE rolling release de la que hablaba.

  • Primero como siempre eliminamos o inhabilitamos cualquier repo que tenga que ver con KDE

opensuse_repo_current_image2

  • A continuación añadimos los nuevos repositorios de KDE:Current y KDE:Current Extra (hacemos un zypper refresh antes) ejecutando como root
zypper refresh

 

zypper ar -f http://download.opensuse.org/repositories/KDE:/Current/openSUSE_13.1/ KDE:Current

 

zypper ar -f http://download.opensuse.org/repositories/KDE:/Extra/KDE_Current_openSUSE_13.1/ KDE_Extra:Current

opensuse_repo_current_image3

  • A continuación hacemos una actualización completa de la distribución con el comando dup.
zypper refresh

 

zypper dup --from KDE:Current --from KDE_Extra:Current

opensuse_repo_current_image4

Reiniciamos y ya tenemos con nosotros la última versión de KDE 4.12.4 activada. A mi por ahora me funciona bien (es lo normal en openSUSE)…pero como se dice habitualmente..este tipo de cambios bajo vuestro propio riesgo. 😉

En todo caso los que uséis un repositorio tipo KDE:Release:4x deberías moveros a la versión current, si queréis estar actualizados.

Vía | Tete Plaza (Google +)

33 thoughts on “Activar KDE rolling release en openSUSE con los nuevos repos current”

  1. victorhck says:

    eres un crack!! 😉

    1. tannhausser says:

      Gracias colega…hasta que vi el repo…todavía estaba convencido que era la típica broma del 1 de Abril xD

      1. victorhck says:

        jejeje
        Reblogueando con tu permiso…

      2. victorhck says:

        ups, lo siento, no me deja rebloguear…
        na’ es lo mismo…
        difundiendo por las redes!!

        1. tannhausser says:

          Gracias! no se como es el tema de rebloguear entre wordpress.org y wordpress.com, es posible que no deje…

          1. victorhck says:

            na’ no pasa nada!

  2. C Rainbowarrior says:

    Que maravilla, gracias!!

    1. tannhausser says:

      De nada amigo! Que lo disfrutes!

      1. C Rainbowarrior Orbayo says:

        Ver lo siguiente acojona.. Pensar que es la distribución más estable que elegiste, pensar que zypper es un mounstro, hace que le des al intro…

        Para más tarde comprobar que todo está bien recogido y sin novedad xDD

        carlos@linux-carlos:~> sudo zypper refresh
        root’s password:
        El repositorio ‘Bases de Datos’ está actualizado.
        El repositorio ‘Educacion’ está actualizado.
        El repositorio ‘Juegos’ está actualizado.
        El repositorio ‘KDE3’ está actualizado.
        El repositorio ‘KDE:Current’ está actualizado.
        El repositorio ‘KDE:Extra’ está actualizado.
        El repositorio ‘Kernel-Stable’ está actualizado.
        El repositorio ‘multimedia:Photo’ está actualizado.
        El repositorio ‘Packman’ está actualizado.
        El repositorio ‘Security’ está actualizado.
        El repositorio ‘Sistema de archivos’ está actualizado.
        El repositorio ‘WINE’ está actualizado.
        El repositorio ‘BuildService_de_openSUSE-Virtualización(VirtualBox)’ está actualizado.
        El repositorio ‘google-chrome’ está actualizado.
        El repositorio ‘google-earth’ está actualizado.
        El repositorio ‘libdvdcss’ está actualizado.
        El repositorio ‘multimedia:apps’ está actualizado.
        El repositorio ‘multimedia:libs’ está actualizado.
        El repositorio ‘openSUSE-13.1-Non-Oss’ está actualizado.
        El repositorio ‘openSUSE-13.1-Oss’ está actualizado.
        El repositorio ‘openSUSE-13.1-Update’ está actualizado.
        El repositorio ‘openSUSE-13.1-Update-Non-Oss’ está actualizado.
        Todos los repositorios han sido actualizados.
        carlos@linux-carlos:~> sudo zypper dup –from KDE:Current –from KDE:Extra
        Obteniendo los datos del repositorio…
        Leyendo los paquetes instalados…
        Calculando actualización…

        Problema: k3b-codecs-2.0.2-18.43.x86_64 requiere k3b = 2.0.2-18.43, pero este requisito no puede cumplirse
        Solución 1: desinstalación de k3b-codecs-2.0.2-18.43.x86_64
        Solución 2: mantener el antiguo k3b-2.0.2-18.43.x86_64
        Solución 3: mantener el antiguo k3b-2.0.2-18.43.x86_64
        Solución 4: romper k3b-codecs-2.0.2-18.43.x86_64 ignorando algunas de sus dependencias

        Elija la solución usando ‘1’o cancele usando ‘c’ [1/2/3/4/c] (c): 1
        Resolviendo dependencias…
        Calculando actualización…

        Los siguientes 2 paquetes NUEVOS van a ser instalados:
        gstreamer-0_10-utils libqtcurve-cairo0

        El siguiente paquete va a ser ELIMINADO:
        k3b-codecs

        Los siguientes 134 paquetes van a ser actualizados:
        akonadi akregator ark calligra calligra-doc calligra-krita calligra-l10n-es calligra-l10n-es-doc dolphin dragonplayer
        gtk2-engine-oxygen gtk2-theme-oxygen gwenview homerun homerun-kicker k3b kactivities4 kaddressbook kcalc kcharselect
        kcolorchooser kde4-kgreeter-plugins kde4-l10n-es kde4-l10n-es-data kde4-l10n-es-doc kde4-print-manager
        kdeartwork4-screensaver kdeartwork4-wallpapers kdeartwork4-wallpapers-weather kdebase4-libkonq kdebase4-nsplugin
        kdebase4-runtime kdebase4-workspace kdebase4-workspace-ksysguardd kdebase4-workspace-liboxygenstyle
        kdebase4-workspace-plasma-calendar kdegames4-carddecks-default kdegraphics-thumbnailers kdelibs4 kdelibs4-core
        kde-mplayer-thumbnailer kdenetwork4-filesharing kdepasswd kdepim4 kdepim4-runtime kdepimlibs4 kdialog kdm kdnssd
        keditbookmarks kfind kgamma kget kgpg kio_audiocd kio_kamera kmag kmahjongg kmail kmines kmix kmousetool knotes kompare
        konqueror konqueror-plugins konsole kontact konversation konversation-lang kopete korganizer kpat krdc kreversi krfb kruler
        kscd ksnapshot ksudoku kwalletmanager kwin kwrite libakonadi4 libhomerun0 libkactivities6 libkcddb4 libkcompactdisc4
        libkdcraw23 libkde4 libkdecore4 libkdegames libkdegames6 libkdepim4 libkdepimlibs4 libkerfuffle4 libkexiv2-11 libkipi11
        libkmahjongg libkmahjongglib4 libkomparediff2-4 libkonq5 libksane0 libksuseinstall1 libktexteditor libmarblewidget17
        libnepomukwidgets4 libodfgen-0_0-0 libprison0 marble marble-data marble-doc mobipocket moodbar nepomuk-core okular
        oxygen-icon-theme oxygen-icon-theme-large plasma-addons plasma-addons-akonadi plasma-addons-lancelot plasma-addons-marble
        plasmoid-folderview python-kde4 python-kde4-akonadi python-kde4-khtml python-kde4-knewstuff python-kde4-nepomuk
        python-kde4-phonon python-kde4-plasma python-kde4-soprano python-kdebase4 qtcurve-gtk2 sweeper

        Los siguientes 68 paquetes van a ser desactualizados:
        acetoneiso2 akonadi-runtime amarok apper apper-lang bluedevil bluedevil-lang cln digikam kaffeine kde4-filesystem
        kde4-ROSA-icontheme kde-audio-thumbnail kdebase4-openSUSE kdebase4-runtime-branding-openSUSE
        kdebase4-workspace-branding-openSUSE kde-gtk-config kde-gtk-config-lang kde-odf-thumbnail kde-thumbnailer-msoole
        kde-thumbnailer-ooxml kio_iso kipi-plugins kipi-plugins-acquireimage kipi-plugins-geolocation kmplayer kmplayer-lang
        krename kscreen ksshaskpass ktorrent kvkbd lensfun-data libakonadiprotocolinternals1 libepub0 libkface2 libkgeomap1
        libkscreen libkscreen1 liblensfun0 libmediawiki1 libqalculate5 libqtcurve-utils1 libSoQt20 libssh4 libtag-extras1
        libzipios0 NetworkManager-kde4-libs NetworkManager-kde4-libs-lang NetworkManager-openvpn-kde4 NetworkManager-pptp-kde4
        NetworkManager-vpnc-kde4 partitionmanager partitionmanager-lang plasmoid-networkmanagement plasmoid-quickaccess
        plasmoid-webcamoid python-apsw python-cssselect python-pivy qtcurve-kde4 quick-usb-formatter skanlite skanlite-doc
        skanlite-lang smplayer smplayer-lang synaptiks

        Los siguientes 19 paquetes van a ser reinstalados:
        appmenu-qt calibre choqok digikam-doc faenza-cupertino-icon-theme faenza-cupertino-icon-theme-large kdeconnect-kde
        kdeconnect-kde-lang kdelibs4-branding-openSUSE kdm-branding-openSUSE ksplash-qml-branding-openSUSE
        ksplashx-branding-openSUSE libbluedevil2 libCoin60 libopencv2_4 libqwt6 python-CXX soundkonverter
        susegreeter-branding-openSUSE

        El siguiente paquete va a cambiar la arquitectura:
        plasmoid-webcamoid x86_64 -> noarch

        Los siguientes 12 paquetes van a cambiar de proveedor:
        calligra openSUSE -> obs://build.opensuse.org/KDE
        calligra-doc openSUSE -> obs://build.opensuse.org/KDE
        calligra-krita openSUSE -> obs://build.opensuse.org/KDE
        calligra-l10n-es openSUSE -> obs://build.opensuse.org/KDE
        calligra-l10n-es-doc openSUSE -> obs://build.opensuse.org/KDE
        k3b http://packman.links2linux.de -> obs://build.opensuse.org/KDE
        libodfgen-0_0-0 openSUSE -> obs://build.opensuse.org/KDE
        libprison0 openSUSE -> obs://build.opensuse.org/KDE
        libSoQt20 http://packman.links2linux.de -> obs://build.opensuse.org/KDE
        plasmoid-webcamoid http://packman.links2linux.de -> obs://build.opensuse.org/KDE
        python-pivy http://packman.links2linux.de -> obs://build.opensuse.org/KDE
        qtcurve-gtk2 openSUSE -> obs://build.opensuse.org/KDE

        134 paquetes a actualizar, 68 a desactualizar, 2 nuevos, 19 a reinstalar, 1 a quitar, 12 a cambiar de proveedor, 1 a cambiar
        arquitectura.
        Tamaño total a descargar: 421,9 MiB. Después de la operación, se utilizarán 4,0 MiB adicionales.
        ¿Desea continuar? [s/n/? mostrar todas las opciones] (s): s

  3. jaitrum says:

    CAmbiado y actualizado todo en menos de 5 minutos.. Me ha dado la impresión de que todo ha ido rapidísimo! 🙂

  4. Felipe says:

    Por este tipo de artículos este blog es mi preferido y el qué más influye sobre los programas qué tengo instalado en mi PC , comenzando con OpenSUSE.

    1. tannhausser says:

      @Felipe Hey! Muchas gracias amigo!

      Espero seguir siendo una buena influencia mucho tiempo 🙂

      Un saludo!

      1. moscosov (@moscosov) says:

        Jajajajaja a mi me pasa algo parecido a @Felipe, leí esta noticia ayer en la mañana, en un sitio del cual no recuerdo el nombre (mukta… algo) y no le tome mayor asunto, la leo en el Replicante y no lo pensé 2 veces para cambiar repositorios y hacer un zypper up… la verdad Tannhausser, no se que tan buena influencia puedes ser para la estabilidad de nuestros sistemas… xD

        1. tannhausser says:

          Bueno esperemos que no se rompa nada! sino en los foros de opensuse me van a odiar xD

          El blog que comentas es muktware y es de mis preferidos, además el editor principal (ahora tiene más gente contratada haciendo post) es usuario habitual de openSUSE.

          El caso es que la noticia salió el lunes en la comunidad de openSUSE en Google+, pero como decían que se activaría el 1 de abril (día de los inocentes en US) no me quise arriesgar a publicarla hasta que estuviera el repo activo y pudiera comprobar que no era una broma xD

          A veces uno se pasa de desconfiado 😉

  5. Inferat Vladimirvr Vras says:

    A probar se ha dicho…. un complemento más para tener nuestro openSUSE a punto…!! gracias!

    1. tannhausser says:

      De nada Inferat!
      Gracias a ti por comentar!

  6. xman says:

    Saludos tannhausser, instalado sin problemas solo uno que otro conflicto de de dependencia pero nada a mayores. Tengo una pregunta, seguimos manteniendo a “packman” con mayor prioridad??? , es que cuando le e dicho cambiar a este repositorio me a pedido unos cuantos cambios entre ellos bajar la versión de algunos programas.

    1. tannhausser says:

      Al hacer la actualización desde los nuevos repos algunos paquetes que proveía packman seguramente fueron desplazados. Yo no tocaría nada de las prioridades si son pocos paquetes.

      En un caso extremo se podría hacer un zypper dup, pero es demasiado arriesgado y no lo recomiendo en absoluto.

  7. xman says:

    Gracias, seguiré tu consejo. Ves que si eres una buena influencia. LOL

  8. Inferat Vladimirvr Vras says:

    Solo me brinco el problema con los codecs de k3b…. aparte de eso, todo anda fluido y rapido, como es costumbre en openSUSE + KDE

  9. D'Artagnan says:

    Me sorprende ver tantos repositorios.Me han parecido 17 y todos con la misma prioridad.

  10. C Rainbowarrior says:

    Por cierto, los Flattr icons de KAOS, quedan SOBERBIOS en openSUSE!! 😀

    1. tannhausser says:

      Doy fe 🙂

  11. C Rainbowarrior Orbayo says:

    Esto sería como tener tumbleweed?? Ya uso el kernel de tumbleweed..
    Tubleweed no hace a opensuse una rolling release, (pero es casi como eso, no?) y dicen que no se aconseja si quieres un sistema estable. Que sólo es para entusiastas.
    Me estoy perdiendo un poco….

    1. tannhausser says:

      Es parecido pero diferente…en este caso lo único que se vuelve (casi) rolling release es KDE utilizando siempre la última versión estable.
      Es decir sólo el entorno de sistema, no el resto de aplicaciones como puede ser con tumbleweed: firefox, libreoffice, etc..

  12. C Rainbowarrior Orbayo says:

    He estado mirando, y si no me equivoco, este repo no pertenece a tumbleweed. Mucho más claro ahora, gracias replicante!!

  13. Virgilio says:

    Esto esta genial pero…,después de instalar los repos y actualizar me quedaron dos núcleos:

    Kernel 3.11.6-4-desktop el antiguo y;

    3.11.10-7-desktop el nuevo.

    ¿eliminamos el antiguo?

    1. xman says:

      Si solo tienes dos, por ahora no lo borraría, siempre tengo el ultimo kernel estable y conservo el anterior por un tiempo, si luego no hay fallos, pues lo borro, pero dejarlo solo afecta el espacio de la /.

      Saludos

      1. Virgilio. says:

        ¡Gracias xman! sabiendo que no causa inestabilidad se me hace muy sensato tú consejo, así lo haré.

        Saludos.

  14. icapoc says:

    Estoy usando Tumbleweed + estos repos KDE y va muy bien, Kernel 3.14.0-23 y KDE 4.12.4… un avión.

  15. Angelo says:

    Una pregunta, ¿Tienes los repos de Update activados?

  16. Gustavo says:

    Luego de hacer esto, amarok y k3b no se actualizan.
    Se puede hacer algo porque siempre me aparecen que hay actualizaciones para los mismos, pero al darle a instalar me da error “no se ha podido encontrar una dependencia del paquete”.
    Desde ya, gracias y excelente blog. Saludos

    1. tannhausser says:

      Puedes probar en Yast a cambiar de proveedor de esos programas o averiguar la dependencia o versión del paquete que falta.

      Aunque yo no me preocuparía demasiado…seguramente se actualicen en sucesivos updates.

      Un saludo y gracias por seguir el blog!

Deja un comentario