Disponibles los drivers AMD Catalyst para openSUSE 13.2 y Tumbleweed

gecko

Los propietarios de gráficas AMD/ATI que precisen instalar el driver propietario FGRLX en la última versión estable de openSUSE 13.2 o en su rolling release Tumbleweed ya lo pueden hacer gracias al trabajo de Sebastian Siebert.

La manera más sencilla de instalarlos si utilizamos openSUSE 13.2 es mediante click install que añade automáticamente el repositorio y los paquetes necesarios (fgrlx-core, fglrx-graphics, fglrx-amdcccle, fglrx-opencl, fglrx-xpic)

  • instalar FGLRX para 32 bits

opensuse_1click

  • instalar FGLRX para 64 bits

opensuse_1click

Este método por ahora no funciona con openSUSE Tumbleweed por lo que es necesario añadir el repositorio de AMD-fglrx de forma manual a través de Yast2, tal como nos explican en la wiki de openSUSE

Así que nos vamos a Yast2 y seguimos la ruta habitual Configuración > Repositorios > Añadir y en “especificar url” añadimos el nuevo repo para openSUSE Tumbleweed

http://geeko.ioda.net/mirror/amd-fglrx/openSUSE_Tumbleweed/

y le ponemos el nombre que más nos guste FGLRX_AMD o simplemente FGLRX

urlrepoamd_opensuse

Este mismo método lo podéis utilizar también para openSUSE 13.2 ya que lo único que cambia es la dirección del repositorio:

http://geeko.ioda.net/mirror/amd-fglrx/openSUSE_13.2/

repoamd_activado_opensuse

Una vez instalado y nos hayamos asegurado de que el repo esta habilitado tan solo nos falta instalar eses 5 paquetes que os había mencionado al principio: fgrlx-core, fglrx-graphics, fglrx-amdcccle, fglrx-opencl, fglrx-xpic (32 o 64 bits depende de la versión de openSUSE que tengamos instalada)

amd_rpm

En mi caso todos mis equipos funcionan con Nvidia e Intel, así que obviamente no los llegué a instalar por lo que no os puedo decir si el rendimiento es superior o inferior a los drivers libres Radeon Gallium3D.

Eso si, deciros por lo que he estado leyendo en los foros de openSUSE (inglés y español) funcionan razonablemente bien sobre todo si son gráficas exclusivamente AMD, en los casos de híbridos Intel/AMD ojeando los comentarios del blog de Sebastien Siebert parece que está dando más problemas.

Vía | Lizards openSUSE

Imagen gecko | Martha Heinemann Bixby (CC BY-NC 2.0)

11 thoughts on “Disponibles los drivers AMD Catalyst para openSUSE 13.2 y Tumbleweed”

  1. shadow says:

    Justo estoy revisando openSUSE 13.2 para el blog y esto me viene de perlas. Lo que ocurre es que el enlace 1-click que has puesto apunta al repositorio del código fuente (raw-src) y no funciona, la ruta correcta es:

    http://geeko.ioda.net/mirror/amd-fglrx/ymp/amd-ati-fglrx64.ymp

    para 64 bits y:

    http://geeko.ioda.net/mirror/amd-fglrx/ymp/amd-ati-fglrx.ymp

    para el de 32.

    Gracias por los enlaces y un saludo 🙂

    1. tannhausser says:

      Gracias por el aviso Enrique! Ahora lo reviso 🙂

      Un saludo!

    2. Solrak Rainbowarrior says:

      Tienes que usar firefox y se abre el yump. Chrome no lo hace.

  2. brutico says:

    Yo me quedo con los libres, estos no lo he probado pero siempre han ido mal. “Me refiero que se arrastra hasta viendo una pelicula

  3. josejacomeb says:

    Genial! Una Pregunta también hay los drivers Catalyst-Legacy para OpenSUSE? Instale Linux Mint 16 a un amigo pero esa PC hierve… Quisiera probar con openSUSE y esperar que haya los drivers sean los correctos

    1. tannhausser says:

      Me temo que no! la última versión de ese controlador en opensuse a partir de 12.3 ya no funciona. De todas maneras muchas personas dicen que su equivalente en drivers libres ofrecen mejor rendimiento

  4. Ezequiel says:

    Hola! Sabes que tal van los drivers de Intel en 13.2? Acabo de comprar una laptop nueva y no quiero arruinar la batería como me pasó antes 🙁

    Otra cosa, cuando probé 13.2 quise desinstalar algo de software (digiKam por ejemplo) y cuando vuelvo a iniciar YaST2 automáticamente quiere instalar los paquetes que borré. No sé como hacer para que no lo haga!

    Saludos

    1. tannhausser says:

      @Ezequiel En el equipo que tengo con openSUSE es una tarjeta Nvidia (pura por así decirlo) pero en general los drivers de Intel funcionan de maravilla en la mayoría de distros, lo de la batería que comentas no es habitual.

      Lo de digikan así sin ver la salida que te da YaST2 es ir un poco a ciegas, lo más seguro que es sea un problema de dependencias o paquete huerfano.

      Por eliminar probabilidades puedes probar a instalarlo otra vez y volverlo a eliminar ejecutando como root

      zypper remove -u digikam

      Ese comando lo que hace es cargarse todas las dependencias innecesarias.

      También lo puedes hacer desde Yast (de paso le puedes echar un vistazo a los paquetes que tienes huerfanos) en la siguiente ruta yast2 > opciones > limpiar durante la eliminación de paquetes

      Saludos!

      1. Ezequiel says:

        El tema es que en 13.1 no era necesario ejecutarlo como administrador ni poner la opción de limpiar paquetes, veo que es algo que cambió en esta versión. Es como si los paquetes de la distro original no pudieran borrarse y la misma se reconstruyera cada vez que desinstalas estos componentes.

        Me pasa con cualquier paquete que venga en la instalación limpia: Amarok, Marble, DigiKam, kipiplugins, etc.

  5. Rene Alexander Alvarez says:

    Se agradece la noticia, en mi caso el driver libre me baja los clock del procesador, no puedo ocupar el opencl y me genera alguna molestia con el dual monitor.
    El enlace que ocupe fue el de shadow porque en una parte de la descarga se congeló, pero todo bien, le estoy dando una oportunidad a opensuse 13.2 porque las versiones anteriores no se portaban bien con el hardware híbrido AMD de mi notebook

  6. josejacomeb says:

    Genial! Un amigo tiene una PC con Radeon HD 3000 y quisiera saber si hay el Driver Legacy en openSUSE para intentar con el Gecko… Saludos

Deja un comentario