Firefox será capaz de ejecutar extensiones de Chrome

firefox32En Mozilla están decididos a revolucionar uno de los puntos fuertes de su navegador Firefox, como es su sistema de complementos, mediante una nueva API llamada WebExtensions, que permitirá la construcción de extensiones compatibles con las de Chrome, Opera y en futuro incluso Microsoft Edge.

De esta forma comentan en el blog de Mozilla, será mas sencillo para los desarrolladores crear y mantener sus extensiones, al utilizar un modelo estándar válido para múltiples navegadores y compatible con la Blink API de Chromium.

Este movimiento también viene motivado por la llegada de una tecnología nueva llamada electrolysis que añade una capa de seguridad mediante sandboxing separando los procesos por pestañas y de paso optimizando el rendimiento, lo que obliga también a que los add-ons sean multiproceso.

Este cambio supone abandonar el modelo basado en XUL y XPCOM para estas extensiones, a las cuales Mozilla retirará su soporte en una fecha sin determinar,posiblemente en unos 12-18 meses.

Otra novedad es que las extensiones deberán ir firmadas y tendrán que superar un proceso de validación que será obligatorio a partir de Firefox 42, que un principio será manual y después se automatizará para reducir plazos. La idea es proteger a los usuarios de amenazas de malware y adware.

Para que los desarrolladores no tengan problemas a la hora de probar sus extensiones, tendrán la opción de deshabilitar dicha firma en los canales de desarrollo Nightly y Developer Edition

La nueva API WebExtensions, debutará de forma oficial en la edición 43 de Firefox, cuyo lanzamiento está previsto a mediados del mes de diciembre.

Aunque en un principio la idea de tener extensiones validas para cualquier navegador suena bastante bien, no han faltado las críticas de desarrolladores ante el cambio de API, entre otras cosas por el trabajo que tendrán que hacer en antiguos complementos para que estos funcionen en próximas versiones (los creados con Jetpack SDK lo tendrán más fácil) y el abandono de aquellas características que definían a Firefox como un navegador único diferente al resto.

Imagen | Francesco Lodoro (CC BY-NC-SA 2.0)

5 thoughts on “Firefox será capaz de ejecutar extensiones de Chrome”

  1. pepe says:

    Me parece francamente absurdo cambiar todas la extensiones que hay, para adoptar el estándar de Chrome que no se caracteriza por la privacidad.

  2. jcsl says:

    Hola.

    Yo considero la interoperabilidad como algo muy importante. Un sistema de extensiones compatible entre navegadores es un paso adelante. No sé si hay algún estándar en desarrollo sobre esto, pero si no lo hay se debería hacer. Facilitaría el cambio de un navegador a otro, la programación de extensiones ─porque no tendrían que aprender el método específico de cada navegador─ y el beneficio para los desarrolladores tanto en tiempo como en posibles donaciones al llegar su trabajo a más usuarios.

    El navegador en sí debe centrarse en dar algo que marque la diferencia con los demás: implementación y cumplimiento de los estándares web, mayor eficiencia en el uso de recursos, tener una mejor interfaz, estar presente en más plataformas, seguridad, privacidad, …

    Ahora mismo es frecuente leer comentarios en los que la gente escribe que, aunque no les satisface mucho, siguen “atados” al navegador que usan porque son dependientes de tal o cual extensión. Y si de todas formas había que cambiar el modelo para adaptarlo al multiproceso, elegir uno que pretende ser más compatible es un acierto. Vale que es un engorro tener que adaptar las extensiones existentes, pero de todas formas habría que hacerlo en algún momento.

    Un saludo.

  3. Svante says:

    Bien por Firefox, menos cosas por las que destacarse, y justo con su punto fuerte histórico, su capacidad de ser personalizable mediante extensiones. Así seguro que recuperan el market share.

    1. Rotietip says:

      Svante, ojala que eso sea sarcasmo por que me parece una mierda que a los de Mozilla solo les interese soplarles el ojete a los usuarios conformistas de Chrome cambiando a un sistema de extensiones menos versátil que el que tienen actualmente (el Australis de los cojones y el gilipollezco sistema de versionado también es puro estiércol pero al menos es tolerable dentro de lo posible).😠
      Espero que al menos saquen algún “modo de compatibilidad” para el montón de extensiones que después quedaran en el camino (en especial las antiguas que aun funcionan en versiones recientes del navegador).😡

Deja un comentario