Llega Ubuntu 16.04.2 LTS con nuevo kernel

Se ha hecho esperar pero ya tenemos con nosotros a Ubuntu 16.04.2 LTS. Se trata de una versión de mantenimiento, en la que se corrigen errores previos, y se mejora el soporte de hardware en la distro.

La mayoría de bugs solucionados de tipo general provienen del proceso de instalación y actualización. En el apartado del escritorio destacan los relativos a Unity y la biblioteca Oxide-qt, mientras que en la edición server la palma se la llevan los paquetes snap y cloud init.

Como es habitual se ha producido una actualización del kernel y del stack gráfico. Así vemos que Linux pasa de la versión 4.4 a la 4.8 y debutan versiones de X.Org (1.18.4) y Mesa (12.0.6)

Un salto que no se produce de forma automática entre los usuarios actuales de Ubuntu Xenial Xerus. Los cuales si bien al tener su sistema actualizado ya están en 16.04.2 LTS, algo que pueden comprobar mediante un:

uname -a & lsb_release -a

no han sufrido la actualización del núcleo y del soporte de hardware. Para ello se necesita ir una linea de comandos más allá:

sudo apt install --install-recommends xserver-xorg-hwe-16.04

Esto habilitaría una nueva política de actualizaciones, provocando la actualización de dichos componentes de forma automática, cada 6 meses (RollingLTSEnablementStack) hasta el fin de ciclo de la distro allá por 2021 (en caso contrario seguimos con el kernel 4.4 y las habituales actualizaciones de seguridad).

La verdad nunca me ha gustado demasiado esta política de actualizaciones de Ubuntu. Ni siquiera ahora con este cambio a un modelo rolling release del denominado Ubuntu Hardware Enablement Stacks. De hecho la gente de Canonical nunca lo ha habilitado de forma predeterminada,se limita a ofrecerlo como una opción para aquellos usuarios con nuevas plataformas de hardware.

Mi recomendación: si el sistema os funciona de forma correcta, pasad de complicaros con nuevo kernel (en realidad no tan nuevo… puesto que el 4.10 está a punto de salir) y en especial con el stack gráfico. A fin de cuentas estamos hablando de una distro de ciclo regular, cuya estabilidad (para lo bueno y lo malo) se basa en el inmovilismo.

En el caso de buscar software estable a la última para eso están las rolling releases, que no hacen este tipo de apaños intermedios y donde tener varios kernels instalados (el más actual y uno LTS suele ser una buena combinación) en sintonía con el resto del software es lo normal.

Los usuarios de Ubuntu 14.04 LTS pueden actualizar directamente a esta versión, al igual que los que utilicen el resto de sabores de la distro: Kubuntu, Xubuntu, Lubuntu, Mythbuntu, Ubuntu Studio, Ubuntu MATE, Ubuntu GNOME y Ubuntu Kylin

Mas información y los enlaces de descarga para aquellos que quieran instalar la distro, como siempre en el anuncio oficial.

23 thoughts on “Llega Ubuntu 16.04.2 LTS con nuevo kernel”

  1. nickd says:

    Hola, una consulta respecto al tema
    tengo instalado ubuntu studio y cuando salio la actualizacion de x.org y mesa y elimino vlc
    lo googlee y vi que otras distribuciones tenian el mismo problema y hablaban de una version de mesa que se actualizo y vlc necesitaba una anterior.
    en fin sera buena idea pasar este comando
    sudo apt install –install-recommends xserver-xorg-hwe-16.04

    Linux sentey-MS-7758 4.4.0-62-lowlatency #83-Ubuntu SMP PREEMPT Wed Jan 18 15:00:41 UTC 2017 x86_64 x86_64 x86_64 GNU/Linux
    No LSB modules are available.
    Distributor ID: Ubuntu
    Description: Ubuntu 16.04.2 LTS
    Release: 16.04
    Codename: xenial
    [1]+ Hecho uname -a

    o ya teneindo la 16.04.2, es suficiente.
    saludos

    1. tannhausser says:

      No se cual es el bug exactamente, pero podrías intentar con algo menos drástico.

      Por ej probar a instalar VLC mediante esta PPA:

      https://launchpad.net/~videolan/+archive/ubuntu/master-daily

      Un saludo

        1. tannhausser says:

          Acabo de asomarme al portatil de mi novia (usa xubuntu 16.04.2) y como referencia te cuento que ella tiene vlc 2.2.2.5 y mesa 12.0.6.

          A partir de los repositorios principales sin PPA y por lo que me ha dado tiempo a mirar esa combinación no da incompatibilidad, y el programa se ejecuta normalmente.

          1. nickd says:

            si, esa debe de ser una version anterior, a mi cuando se actualizo me borro vlc
            aclaro que lo borro con mi permiso
            /**************/intentando instalar vlc
            sudo apt-get install vlc browser-plugin-vlc
            /**************/
            La siguiente información puede ayudar a resolver la situación:

            Los siguientes paquetes tienen dependencias incumplidas:
            vlc : Depende: libgles1-mesa (>= 7.8.1) pero no va a instalarse o
            libgles1
            E: No se pudieron corregir los problemas, usted ha retenido paquetes rotos.

            y no hay actualizaciones pendientes

      1. Señor Paquito says:

        Hola.

        Sé que es una entrada antigua y que, probablemente, nadie lea esto, pero el caso es que estaba teniendo problemas de dependencias con VLC imposibles de solucionar, con la versión de Ubuntu 16.04 tenía unos y con el PPA stable daily tenía otros, pero era imposible reinstalarlo, porque instalado estaba, como le pasó a nickd.

        Buscando la solución llegué a los comentarios de este artículo y aquí estaba la solución, en el PPA que propone tannhausser, que, por cierto, yo no conocía:

        https://launchpad.net/~videolan/+archive/ubuntu/master-daily

        VLC instalado y funcionando.

        Gracias, tannhausser.

        Saludos.

        1. nickd says:

          Hola, el problema de aquel entonces era por culpa de mi tarjeta grafica que chocaba con las dependencias de vlc, ahorita lo acabo de volver a instalar y funciona
          aunque tenia a mpv como reproductor, tendra que compartir ahora con vlc
          gracias por hacer que me acuerde de vlc y su comentario hizo que vuelva a estar instalado en mi sistema.
          Gracias.

        2. tannhausser says:

          A los ojos de Tux todas las entradas son igual de valiosas, tanto antiguas como nuevas.
          Gracias a ti por el aporte 🙂

  2. Destino says:

    Yo no veo nada mal el cambio, de hecho para mi es una grandísima noticia. Tengo una AMD RX 480 que no está soportada por el kernel 4.4 que lleva Ubuntu 16.04, ni si quiera inicia la instalación del sistema. La solución pasaba por instalar Ubuntu 16.10, pero los nuevos drivers privativos de AMD solo son compatibles con Ubuntu 16.04.

    Resumiendo, no podía tener Ubuntu 16.04 con el driver privativo que obtiene un mejor rendimiento gráfico que los libres. Parece que los últimos libres con Mesa 13 o 17 van mejor que el privativo, pero manteniendo Mesa 12 este Ubuntu 16.04 seguro que rinde mejor el privativo.

    Me conformo con poder instalar la LTS, que antes ni eso…

    1. nickd says:

      claro, no estoy en contra de ello, solo comento lo que me paso y preguntaba si sera buena actualizar el kernel

  3. Jorge Moncayo says:

    ¿Saben si el famoso bug de consumo excesivo de RAM se solucionó con esta actualización? Siempre me agradó la 16.04 excepto por ese famoso bug, por eso aun ando en la 14.04.

    1. Einar says:

      Y por un famoso bug, ya no pruebas una distro?, jajaja, un bug no necesariamente afecta a todo el mundo, yo uso la 16.04 y ni había oído hablar de ese bug y no he visto que yo lo sufra.

      1. Jorge Moncayo says:

        Te felicito por no padecer el bug, si no sufrías el bug fácilmente debiste ignorar mi pregunta y no andar de entrometido.

    2. nickd says:

      yo he estado con ubuntu studio desde la version 12 y sigo con el, aun con los altibajos que se presentan, yo simpre estoy encima del rendimiento del equipo y nunca vi ese bug de RAM.
      Y eso que he probado varias distribuciones y no he podido encontrar un sustituto de ubuntu studio
      Saludos

    3. Jorge Romero says:

      aun sigue el problema de al fuga de RAM

      1. Jorge Moncayo says:

        Gracias, es una látima. 🙁

  4. lcausilla says:

    Mi laptop (traída por Cristobal Colon en el segundo viaje a las Américas) resistió sin problemas el cambio de 4.4 a 4.8 en mi Lubuntu 16.04.2 LTS, es cierto lo que dicen de que ya teniamos la actualizacion (por mis redes sociales andan los printscreen con el uname -a) pero solo hice el cambio no por la nueva politica sino mas bien para ver que tan le iba al Hardware viejo que tengo con el nuevo kernell… hasta ahora todo bien

    1. nickd says:

      como actualizastes el kernel

      1. lcausilla says:

        Normal… haces un sudo apt install –install-recommends xserver-xorg-hwe-16.04 y cuando termina el proceso de actualizacion sales con un flamante kernell 4.8 y un stack de graficos nuevos.

        1. nickd says:

          gracias, lo probare

  5. sadalsuud says:

    yo actualicé pero … me sigue saliendo el kernel 4.4 …. 😐

  6. Platonov says:

    La versión 16.04 no ha tenido suerte conmigo. Instalé varios derivados de Ubuntu 16.04 , 16.04.1 (xubuntu, ubuntu mate, Mint 18…). … en 3 ordenadores distintos y me ha dado siempre muchos problemas ( Mint 18.1 ya empieza a funcionar bien). Que conste que hablo de mi experiencia.
    De momento he decidido saltarme la versión 16.04, o esperar a futuras actualizaciones.
    No se si os ha pasado algo parecido.

  7. Replicante says:

    Si queremos solo actualizar el kernel podemos ejecutar lo siguiente: sudo apt-get install linux-generic-hwe-16.04-edge
    Practico si queremos actualizar el kernel de nuestro servidor o en el caso de un ordenador, actualizar solo el kernel.

    Más info: http://news.softpedia.com/news/ubuntu-16-04-2-lts-lands-january-19-2017-with-ubuntu-16-10-s-linux-4-8-kernel-510572.shtml

Deja un comentario