Disponible Geany 1.25 con soporte GTK3

geanyGeany es uno de mis programas preferidos en GNU/Linux, de esos que acabas cogiendo cariño porque has empezado a usarlo prácticamente desde su primera versión, allá por 2005.

Hablamos de un editor de texto rápido y ligero, con una interfaz flexible, capaz de proporcionar las funciones básicas de un IDE y que va bien en cualquier entorno ya que arrastra muy pocas dependencias GTK.

Un programa “pequeño” pero con muchas funciones interesantes: resaltado de sintaxis, plegado de código, soporte de multitud de tipos de archivos y lenguajes de programación (Python, C, Java, Ruby, PHP, JavaScript, Pascal…) ,emulador de terminal para ejecutar nuestro programa, autocompletado, muestra de consejos, depuración de código, listas de símbolos, sangría automática, cierre automático de etiquetas XML y HTML, además de varios plugins que extienden sus capacidades.

Ahora acaba de salir la versión 1.25 que nos trae de regalo el soporte GTK+3, que si bien no viene establecido por defecto, ahora ya es considerado estable.

Ademas mejora el soporte para los usuarios de OS X y soluciona varios bugs en Windows, se amplia la lista de tipos de archivos admitidos (ahora puede manejar CoffeeScript, JSON y Zephir), se produce una gran mejora en el rendimiento de gestión de etiquetas, visualización de diálogos directamente en el editor de texto, posibilidad de desactivar la lista de archivos recientes, y sistema de búsqueda más eficaz al incluir soporte para expresiones regulares de una sola linea.

Al mismo tiempo se han añadido 4 nuevos plugins: Automark, GeanyCtags, GitChangeBar, Overview (incluidos todos ellos en el paquete geany-plugins), actualizado las bibliotecas de Scintilla (3.5.6) que es uno de los componentes claves del programa y añadido nuevas traducciones, entre otras muchas mejoras.

Geany es un software con licencia libre, disponible para multitud de sistemas operativos como Linux, OS X, Solaris, Windows y toda la familia BSD. Estando presente en los repositorios de la mayoría de distribuciones GNU/Linux (los usuarios de Ubuntu disponéis de esta PPA que ofrece las últimas versiones).

4 thoughts on “Disponible Geany 1.25 con soporte GTK3”

  1. MrSister says:

    perfecto! es muy editor grafico por defecto 🙂

  2. Sli says:

    Este editor lo conoci en #! simplemente lo usaba como editor de textos normal para scripts y otras cosas sencillas, mas tarde empeze a programar un poco y mi sorpresa que mi edtor de textos favorito tambien seriva para programar y bien que lo hace, es evidente que no esta al nivel de un ide especialicado pero cumple su tarea perfectamente y es extremadamente ligero, lo unico que me sorprende es que muchas distros no lo lleven por defecto y prefieran mousepad o leaplaf o alguno de esos que me parecen horrorosos

  3. reisilver says:

    Yo lo use muy poco por alla en el 2008 para programar algunos sripts, cosas sencillas , dando los primeros pasos en el mundo de la programacion, me alegra saber que sigue desarrrollandose y corrigiendose bugs por parte de su equipo de desarrollo , y ahora con soporte gtk3 pues bien valdria la pena darle una oportunidad haber que tanto a mejorado a dia de hoy , gracias por el post . Me pregunto si soporta ruby ….

  4. Rene Alexander Alvarez says:

    En realidad no conozco un competidor para geany, así que es lo primero que instalo ya sea en windows o Linux, lo ocupo mucho por el manejo de expresiones regulares cuando hay que hacer reemplazo de texto de manera masiva y en múltiples archivos.

Deja un comentario